The Center for Teaching, Learning, & Technology

Instructional Technology Workshops

Microsoft Excel 2010
Formulas and Charts
Albert Robinson / Delwar Sayeed

Faculty and Staff Development Programs

Colston Hall Room 226
718-289-5100 ext. 3142
Excel 2010 Formulas and Functions

One of Excel’s most useful features is that it allows users to create custom formulas to perform calculations on their data. Excel also contains built-in formulas called functions that make it easy to perform common calculations on data. Here you will find step by step tutorials, tips and shortcuts on how to use formulas and the common and less common functions available in Excel.

**Formula Basics**

Formulas in Microsoft Excel begin with an equal sign. The equal sign tells Excel that the succeeding characters constitute a formula. If you don’t enter the equal sign, Excel will treat your entry as text and the calculation will fail.

To show how formulas work, we’ll begin with a simple exercise by selecting blank cell A1. Then type =5+5, and press Enter. Excel performs the calculation and produces a result of 10 in cell A1.

Notice the formula bar shows the formula you just typed. What appears in the cell is the result; what appears in the formula bar is the underlying value, which is a formula in this case.

**Order of Operation**

When performing calculations in a formula, Excel follows certain rules of precedence: Excel calculates expressions within parentheses first. Excel calculates multiplication and division before addition and subtraction. Excel calculates consecutive operators with the same level of precedence from left to right.

For example, the formula = 10+10*2 gives a result of 30 as Excel multiplies 10 by 2 and then adds 10. However, the formula =(10+10)*2 produces a result of 40. This is because Excel calculates the expression (10+10) within the parentheses first. It then multiplies by 2.

If you are unsure of the order in which Excel calculates, use parentheses - even if the parentheses aren’t necessary. Parentheses also make your formulas easier to read.

---

<table>
<thead>
<tr>
<th>Operations in Formulas</th>
</tr>
</thead>
<tbody>
<tr>
<td>: Colon</td>
</tr>
<tr>
<td>Single space</td>
</tr>
<tr>
<td>, Comma</td>
</tr>
<tr>
<td>- Negation (as in -1)</td>
</tr>
<tr>
<td>% Percent</td>
</tr>
<tr>
<td>^ Exponentiation</td>
</tr>
<tr>
<td>* Multiplication</td>
</tr>
<tr>
<td>/ Division</td>
</tr>
<tr>
<td>+ Addition</td>
</tr>
<tr>
<td>- Subtraction</td>
</tr>
<tr>
<td>&amp; Connects two strings of text</td>
</tr>
<tr>
<td>= Comparison (Equal to)</td>
</tr>
<tr>
<td>&lt; Less Than</td>
</tr>
<tr>
<td>&gt; Greater Than</td>
</tr>
</tbody>
</table>
With the new Excel Formula Bar the majority of all formulas you may need are at your fingertips. For example: a Math professor is interested in determining which formula would be best to convert radians to degrees. We will go to the Formula Tab, and select the Math & Trig downward arrow.

**Basic Formulas**

Create a Formula with Function

1. Click the cell in which you want to enter the formula.
2. Click **Insert Function** on the formula bar. Excel inserts the equal sign ( = ) for you.
3. Select the function that you want to use. If you're not sure which function to use, type a question that describes what you want to do in the Search for a function box (for example, "add numbers" returns the **SUM** function), or browse from the categories in the Or Select a category box.
4. Enter the arguments.
5. After you complete the formula, press ENTER.
Use Auto Sum

To summarize values quickly, you can also use **AutoSum**.

1. Select the cell where you would like your formulas solution to appear.
2. Go to the **Home** tab, in the **Editing** group,
3. Click **AutoSum**, to sum your numbers or click the arrow next to **AutoSum** to select a function that you want to apply.

![AutoSum](image)

Add the Values in Rows or Columns

Use the **SUM** function, which is prewritten formula, to add all the values in a row or column:

1. Click your mouse in the cell in which you wish your result to appear
2. Click the **AutoSum** button on the **Home Tab** or the **Formulas Tab**
3. Highlight the range of cells you wish to add
4. Press **Enter**

To add some of the values in a column or row:

1. Type an equal sign, type **SUM**, then type an opening parenthesis.
2. Type or select the cell references you want to add. A comma (,) separates individual arguments that tell the function what to calculate
3. Type a closing parenthesis, and then press ENTER. For example: =SUM(B2:B4, B6) and =SUM(B2, B5, B7)

Find the Average, Maximum, or Minimum

Use the **AVERAGE**, **MAX**, OR **MIN** functions.

1. Click your mouse in the cell in which you wish your result to appear
2. Click the arrow next to **AutoSum** on the **Home Tab** or the **Formulas Tab**.
3. Click the **Average, Max, or Min**
4. Highlight the range of cells you wish to find the value for

5. Press **Enter**

To see more functions, click **More Functions** on the **AutoSum** list to open the **Insert Function** dialog box OR go to the **Formulas Tab** and click on the **More Functions** orange textbook icon.

**Ranges and Individual Cells**

As you start to write Excel formulas, you may realize you want to use a range of cells or nonadjacent cells in your formula. A range of cells will include the value of every cell within the range specified (for example, the range A1:A4 includes the cells A1, A2, A3 & A4). Ranges of cells are identified with a colon.

<table>
<thead>
<tr>
<th>To refer to</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>The cell in column A and row 10</td>
<td>A10</td>
</tr>
<tr>
<td>The range of cells in column A and rows 10 through 20</td>
<td>A10:A20</td>
</tr>
<tr>
<td>The range of cells in row 15 and columns B through E</td>
<td>B15:E15</td>
</tr>
<tr>
<td>All cells in row 5</td>
<td>5:5</td>
</tr>
<tr>
<td>All cells in rows 5 through 10</td>
<td>5:10</td>
</tr>
<tr>
<td>All cells in column H</td>
<td>H:H</td>
</tr>
<tr>
<td>All cells in columns H through J</td>
<td>H:J</td>
</tr>
<tr>
<td>The range of cells in columns A through E and rows 10 through 20</td>
<td>A10:E20</td>
</tr>
</tbody>
</table>

Nonadjacent cells can be listed in the formula by separating them with a comma rather than a colon. For example, =SUM(A2,A4) will add cells A2 and A4, but not A3.

**Copy a Formula**

Using the Fill Handle

1. Select the cell that contains the formula, then position the mouse pointer over the lower-right corner of the cell until the black cross (+) appears.

2. Drag the fill handle over the cell or cells to which you want to copy the formula, then release the mouse button.

Using Traditional Copy & Paste

1. Select the cell that contains the formula, and on the **Edit** menu, click **Copy**.

2. Select the cell or cells that you want to copy it to.

   a. To copy the formula and any formatting, on the **Edit** menu, click **Paste**.

   b. To copy the formula only, on the **Edit** menu, click **Paste Special**, and then click **Formulas**.
Delete a Formula

When you delete a formula, the resulting value of the formula is also deleted. However, you can instead remove the formula only and leave the resulting value of the formula displayed in the cell.

To delete formulas along with their resulting values, do the following:

1. Select the cell or range of cells that contains the formula.
2. Press DELETE.

To delete formulas without removing their resulting values, do the following:

1. Select the cell or range of cells that contains the formula.
2. On the Home tab, in the Clipboard group, click Copy.
3. On the Home tab, in the Clipboard group, click the arrow below Paste, and then click Paste Values.

Referencing Cells in Formulas

You can include or reference other cells in a formula. When you do, the result of the formula depends on the values in the referenced cells and changes automatically when the values in the referenced cells change. This is extremely powerful in what-if scenarios.

<table>
<thead>
<tr>
<th>Column &amp; Row</th>
<th>(A$1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Absolute</td>
<td>(A1)</td>
</tr>
<tr>
<td>Row Absolute</td>
<td>(A$1)</td>
</tr>
<tr>
<td>Nothing Absolute</td>
<td>(A1)</td>
</tr>
</tbody>
</table>

To see how this works, enter 10 in cell A1. Now select cell A2 and type =A1*2, and press ENTER. The value in cell A2 is 20. If you change the value in cell A1 from 10 to any value, the value in cell A2 will also change. Cell references are especially helpful when you create complex formulas, or conduct what-if analysis.

Pressing [F4] repeatedly over a reference (cell) will allow you to switch between making the column, the row, or nothing ‘Absolute.’

Relative References

By default Excel uses Relative Referencing. In relative reference, you actually refer to cell that is above or below or left or right to a number of rows or columns. For example, if you refer to cell D2 from F2, you are actually referring to a column that is two columns to the left of cell D2 and in the same row (the second '2'row). When a formula that possesses a relative reference is copied from one cell to another cell, the value in the copied cell also changes. i.e., if you copy a formula =C2+D2 from E2 to the cell F2, the formula in F2 adjusts in such a way that when the cell F2 is dragged downwards by one row, the formula automatically changes to C3+D3 and places the resulting value of C3+D3 in cell F3.
Absolute References

In case, if you wish to maintain the original references as they were, then you should make use of the absolute references. If you want to make the above example retain the original reference when it is copied, then you should precede the columns A2 and B2 and the row number by a Dollar ($) symbol. i.e., you should use the formula as =$C$2+$B$2 so that when you copy the formula the original reference is retained.

To make the cell appear in absolute format ($) click on the cell you would like to edit and press [F4] and press enter. You will observe the cell A1 turn into =$A$1.

For example, if you copy or fill an absolute reference in cell B2 to cell B3, it stays the same in both cells =$A$1.

Mixed References

In some situations, you may need to make the cell reference as ‘Mixed’ reference, so that you can lock either a column or a row by preceding it with a Dollar ($) symbol. For example, if you use a formula as =$D4+E4, then you are making the value that is present in cell D4 as absolute and the value in cell E4 as Relative.

References to Other Worksheets

You can refer to cells in other worksheets within the same workbook just as easily as you refer to cells in the same worksheet. For example, to enter a reference to cell A2 in Sheet2 into cell A1 in Sheet1, do this:

1. Select cell A1 in Sheet1, and type an equal sign.
2. Click the Sheet2 tab.
3. Click cell A2, and then press Enter.

After you press Enter, Sheet1 is now active. Select cell A1, and you will see that it contains the formula =Sheet2!A2.

The exclamation point separates the worksheet portion of the reference from the cell portion.

Other Workbook References

You can refer to cells in worksheets in other workbooks in the same way you refer to cells in other worksheets within the same workbook. These references are called external references. For example, to enter a reference to Book2 in Book1, follow these steps:

1. Create 2 workbooks; Book1 and Book2
2. Select cell A1 in Sheet1 of Book1, and type an equal sign.
3. Switch to Book2. Click to select A2.
4. Press Enter

After you press enter, your formula in Workbook 1, Cell A1, should be =Book2!Sheet1!$A$2. This reference has 3 parts: The Workbook Book2 in square brackets, the worksheet and the cell. So referencing cells in external workbooks by selecting the workbook, then worksheet, and then the cell you want to reference.

Quick Reference Guide

Add, Subtract, Multiply & Divide

Type an equal sign (=), use math operators, and then press ENTER.

=10+5 to add
=10-5 to subtract
=10*5 to multiply
=10/5 to divide

Formulas are visible in the formula bar when you select a cell that contains a result. If the formula bar is not visible, on the Tools menu, click Options. Click the View tab, and select the Formula bar check box.

Understand Error Values

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#####</td>
<td>The column is not wide enough to display the content. Increase column width, shrink contents to fit the column, or apply a different number format.</td>
</tr>
<tr>
<td>#REF!</td>
<td>A cell reference is not valid. Cells may have been deleted or pasted over.</td>
</tr>
<tr>
<td>#NAME?</td>
<td>You may have misspelled a function name.</td>
</tr>
</tbody>
</table>

Avoid common errors with formulas

The following table summarizes some of the most common errors that you can make when entering a formula and how to correct those errors:

<table>
<thead>
<tr>
<th>Make sure that you...</th>
<th>More information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Match all open and close parentheses</td>
<td>Make sure that all parentheses are part of a matching pair. When you create a formula, Excel displays parentheses in color as they are entered.</td>
</tr>
<tr>
<td>Use a colon to indicate a range</td>
<td>When you refer to a range of cells, use a colon (:) to separate the reference to the first cell in the range and the reference to the last cell in the range. For example, A1:A5.</td>
</tr>
<tr>
<td><strong>Enter all required arguments</strong></td>
<td>Some functions have required arguments. Also, make sure that you have not entered too many arguments.</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Nest no more than 64 functions</strong></td>
<td>You can enter, or nest, no more than 64 levels of functions within a function.</td>
</tr>
<tr>
<td><strong>Enclose other sheet names in single quotation marks</strong></td>
<td>If the formula refers to values or cells on other worksheets or workbooks, and the name of the other workbook or worksheet contains a non-alphabetical character, you must enclose its name within single quotation marks (‘’).</td>
</tr>
<tr>
<td><strong>Enter numbers without formatting</strong></td>
<td>Do not format numbers as you enter them in formulas. For example, even if the value that you want to enter is $1,000, enter 1000 in the formula.</td>
</tr>
</tbody>
</table>
CHARTS AND GRAPHS

Chart Components

1. Chart Area
2. Chart Title
3. Plot Area
4. Legend
5. Y Axis (Values)
6. Data Points
7. X Axis (Categories)
Chart Types

Selecting the right chart or graph will depend on the data you are trying to plot. Below is a listing of the more common types.

**Column Chart:** Charts used to display data arranged in columns and rows. Column charts are useful for showing data over a period of time.

**Line Chart:** Line charts display data that is set over a period of time, data used to display a trend.

**Pie Chart:** Charts used to display single data series.
**Bar Chart:** These charts are similar to column charts but display at a horizontal angle. Used to compare individual items.

**Area Chart:** Chart used to emphasize the magnitude or rate of change.

**Scatter (XY) Chart:** Chart used to show a correlation between values.
Creating a Simple Chart

1. Highlight the data
   
   a) **Highlighting consecutive rows or columns**: Highlight the first row in the range. Hold down the shift key and use your arrow keys to go up or down.

   b) **Highlighting the entire range**: Click and drag with your mouse

   c) **Highlighting non-adjacent rows or columns**: Highlight the first row or column in your range. Holding down your Ctrl key highlight the additional rows or columns in your range.

2. Click on the Insert Tab – In the Charts group, select the down arrow under the chart heading and select a chart type.
Formatting a Chart

1. Right-click on the chart element that you would like to format.

2. Select the format option at the bottom of the list. The name of the option will depend on the element you are trying to format.

You can also use the commands on the Chart Tools Contextual Tab, located on the Ribbon Bar to modify the design, layout and format.
Design Tab

1. **Type**: In this group you have the ability to change the current chart type as well as save the chart as a template for future charts.

2. **Data**: In this group you have the ability to switch the chart elements as well as add data to the chart.

3. **Chart Layouts**: In this group you have the ability to select various predefined layouts for your chart.

4. **Chart Styles**: In this group you have the ability to select various chart styles/colors for your chart.

5. **Location**: In this group you can select where you want the chart to be placed by default the chart is placed in the current worksheet. Charts can be placed either in its own sheet (New Sheet) or in another sheet tab (Object in).
Layout Tab

1. **Current Selection:** In this group you can select and modify sections of the chart.
2. **Insert:** In this group you can insert additional objects on the worksheet.
3. **Labels:** In this group you have the ability to add/change the labels on the chart.
4. **Axes:** In this group you have the ability to add/change axes information on the chart.
5. **Background:** In this group you have the ability to add/change 3-D chart effects.
6. **Analysis:** In this group you have the ability to change analysis information on specific chart types.
7. **Properties:** Name the selected chart.

Format Tab

1. **Current Selection:** In this group you can select and modify sections of the chart.
2. **Shape Styles:** Select a style for the selected shape.
3. **WordArt Styles:** Select a style for the text in your chart.
4. **Arrange:** Select how you would like to arrange the objects in your chart.
5. **Size:** Change the size of your chart area
**Printing**

Chart and data

1. Click on the File tab – click Print

Note: Chart and data must be on the same sheet.

Chart Only

1. Click on the chart

2. Click on the File tab – click Print