Create a survey using Google Forms

You can plan events, make a survey or poll, give students a quiz, or collect other information in an easy, streamlined way with Google Forms.

Google Forms can be connected to spreadsheets in Google Sheets. If a spreadsheet is linked to the form, responses will automatically be sent to the spreadsheet. Otherwise, users can view them on the “Summary of Responses” page accessible from the Responses menu.

You can create a form from your Drive or from any existing spreadsheet.

Create a form from your Drive

To poll, survey, quiz, or otherwise collect information using a form in Google Drive:

1. Go to Drive at drive.google.com.
2. In the new Drive, click New in the top left, hover over More, and choose Google Forms. In the classic Drive, click the Create button in the top left, then Form.
3. In the form template that opens, you can add any questions you’d like. You can also organize your form by adding headers and dividing your form into several pages.
4. If you’d like those who complete your form to see a progress bar indicating how much of your form they’ve completed, check the box labeled “Show progress bar at the bottom of form pages.”

Create a form from a spreadsheet in Google Sheets

To poll, survey, quiz, or otherwise collect information using a form from a spreadsheet in Google Sheets:

1. While working with a spreadsheet, click the Insert menu and select Form.
2. A message will display at the top of the page notifying you that a new form has been created.

   New form created. Add questions here. Dismiss

3. Click Add questions here to begin editing your form, or Dismiss to get rid of this message and continue editing your spreadsheet. (Note: If you dismiss this message, you can edit your form at any time by selecting the Form menu and clicking Edit form.)
4. After creating a form from a Google spreadsheet, you’ll notice a new tab at the bottom of your spreadsheet labeled “Form responses.” As you might have guessed, this is where responses to your form will be added.

   After you’ve created your form, you can add and edit questions, headers, and page breaks. You can also choose how to collect responses to your form.
Add and edit questions, headers, images, videos, and page breaks

Once you’ve created a form, you’re ready to start adding the questions you’d like to ask. If you’d like to give your form some structure, you can also add section headers and page breaks.

Add questions, headers, and page breaks

Add a question

To add a question to your form, click the arrow next to the Add item button and select from the following question types:

- Text — respondents provide short answers
- Paragraph text — respondents provide longer answers
- Multiple choice — respondents select one option from among several
- Checkboxes — respondents select as many options as they’d like
- Choose from a list — respondents select one option from a dropdown menu
- Scale — respondents rank something along a scale of numbers (e.g., from 1 to 5)
- Grid — respondents select a point from a two-dimensional grid
- Date — respondents use a calendar picker to enter a date
- Time — respondents select a time (either a time of day or a duration of time)

Clicking the Add item button — and not the arrow — will initially give you the default question type, text. Once you’ve added a question, you can change its type by selecting from the Question type menu.

When you’ve selected your question type, you can then fill in the possible responses to your question. If you want to further explain your question, add a description to the Help text field. If you want to prevent respondents from leaving a question blank, check the Required question box, which makes sure users answer a question before submitting your form.

When a form is filled out, the names and email addresses of respondents are not automatically gathered. If you want to collect this information, you must add a text field in your form for respondents to fill in their name or email address.
Add a section header

If you'd like to divide your form into sections to make it easier to read and complete, add a section header. From the Insert menu, select Section header.

For each section header, you can add both a section title and a section description.

Add an image

To add an image to your form, click the Insert menu, and select Image. Once you've uploaded the image, you can give it a title and specify what text will appear when someone hovers over the image.

Images in forms aren't attached to or associated with form questions. You can change the position of an image by dragging it up or down in your form.

Add a video

To add a video to your form, click the Insert menu, and select Video. To pick a video, either provide a YouTube video’s URL, or use the search box to search for a video. After selecting one, you can add a title and a caption to the video. You can click and drag one of the video’s corners to resize it, and you can align the video to the left, right, or center of the page by choosing one of the alignment options.
Add a page break

If your form is lengthy and you’d like to make it easier for respondents to fill it out, you can add page breaks. From the Insert menu, select Page break. New pages, like section headers, can have both a page title and a page description.

Edit your form

Edit questions, headers, and page breaks

For each question, header, and page break you’ve added to your form, you can perform the following actions:

- **Edit**: To edit an existing item, just click the Edit button to the right of the question you want to edit.
- **Duplicate**: To duplicate an item, click the Duplicate button to the right of the question you want to duplicate.
- **Delete**: To delete an item, click the Delete button to the right of the question you want to delete.

Randomly order questions and answers

Shuffle question order

If you want respondents to see the questions in a section or page of your form in a random order, check the box next to Shuffle question order in the "Form settings" section at the top of the form. Images and videos in your form will also be shuffled along with the questions.

Shuffle answer order

If you want respondents to see answer options for a question in a random order, click Advanced within the question field and check the box next to “Shuffle option order.” This option works for the following types of questions:

- Multiple choice
- Checkboxes
- Choose from a list
- Grid (will display “Shuffle row order” instead of “Shuffle option order”)

Answers and questions will only be shuffled one time per email address. If you’re sharing your form with a group address, all members of the group will see the same shuffled order. To shuffle differently for everyone in a group, you have to send the form to each group member individually.
Add a theme to a form

If you want to personalize your form or tailor it to your intended audience, you can add a theme to the form.

Add a theme

To add a theme to an existing form:

1. Open the form.
2. Click Change theme in the toolbar.
3. Scroll through the templates in the panel on the right and click the theme you'd like to add to your current form.

Your new theme will automatically be applied and you can continue editing your form.

Copy a theme

You can copy a theme from a form you have previously used or that has been shared with you.

1. Open the form.
2. Click Change theme in the toolbar.
3. Click Choose form under “Copy a theme” at the top of the panel on the right.
4. Scroll through the available forms and click the form that contains the theme you'd like to add to your current form.
5. Click Select and the theme will be applied to your form.

Create a custom theme

If you want even more control over how your form looks, you can create your own custom theme.

1. Open the form.
2. Click Change theme in the toolbar.
3. Find one of the existing templates in the panel on the right to use as a starting point and click Customize under the name of that template.
4. Select a section of the form in the panel on the right to begin editing that section. Some of the options you can customize include:
   - Adding custom images to the header and the page background
   - Choosing font, font size, font color, and paragraph alignment for the form text
   - Choosing a color for the form and page backgrounds

Your changes will automatically be applied and you can continue editing your form by clicking the Edit questions button in the toolbar.
Control your form's page-to-page navigation

If you've divided your form into different pages by adding page breaks, you can specify which users see which pages depending on their answers to questions in your form — sort of like a “Choose Your Own Adventure” story. For example, you can send users who answer “Yes” to a question to page three of your form while sending users who answer “No” to page four.

Here's how to send users to a specific page based on their answer to a certain question:

1. Create a form.
2. From the Insert menu, select either Multiple Choice or Choose from a list. (Note: Only these two question types can be used to direct respondents to specific pages. No other question type can.)
3. Check the box labeled Go to page based on answer.
4. Next to your answers for this question, you'll see drop-down menus which allow you to direct respondents to specific pages in your form depending on their answers. (Note: If you have more than one question with the “Go to page based on answer” box checked on a page, the form respondent will be routed to the page indicated for the last answered question. Otherwise, two “Go to page based on answer” questions might contradict one another. You can also choose to send respondents to the confirmation page based on an answer by selecting Submit form from the drop-down menu.)

Here's how to send users from one page to another specific page:

Suppose you've sent some respondents to page three in your form and you'd like them to see page five, and not page four, next.

1. Create a form.
2. Divide your form into pages by adding page breaks. From the Insert menu, select Page Break.
   - If you'd like, you can name your page break and add a description. This might help you remember where you're directing respondents, and it may also help respondents understand the structure of your form.
3. At the end of each page in your form, you'll see a dropdown menu with options for where to send respondents next. By default, it's set to “Continue to next page,” but you can change it to send respondents to a specific page in your form or to the form's confirmation page. (Note: If a page has a "Go to page based on answer” multiple choice question on it, the respondent’s answer to that question will override any page navigation settings you’ve chosen.)

Choose a form response destination

After you've sent out your form, Google Forms will begin collecting the responses you receive. You'll be asked to choose how you'd like to store these responses. (Note: You can make this choice at any time while editing your form by clicking the Choose response destination button in the toolbar.)
You can choose either to send responses to a spreadsheet, or you can store them only in Forms. If you choose to store them in a spreadsheet, you’ll be able to see individual responses as they come in. If you choose to store them in Forms, you’ll be able to see a summary of all the responses you’ve received, and you’ll also be able to download the responses as a CSV file.

Store responses in a spreadsheet

In the “Choose response destination” dialog, you can choose to create a new spreadsheet in which to store your form’s responses. You can give the new spreadsheet whatever title you’d like. If you’d like all of your forms to collect responses in a new spreadsheet in the future, make sure the checkbox next to “Always create a new spreadsheet” is selected.

Alternatively, you can choose to collect responses in a new sheet of an existing spreadsheet. Choose “New sheet in an existing spreadsheet...” and click Choose. You’ll see a list of your spreadsheets. Pick a spreadsheet by checking the box next to it and click Select. A new sheet will be created in that spreadsheet, and your form responses will appear there. A spreadsheet can collect responses from only one form at a time unless you have switched to the new Google Sheets, which allows responses from multiple forms to be stored in the same spreadsheet.

Once you’ve chosen to store form responses in a spreadsheet, the Choose response destination button in the toolbar will turn into a View responses button. Click this to see your spreadsheet. You can also find the spreadsheet in your Drive.

Note that responses sent to a spreadsheet are essentially a copy of your responses and are only sent one way — form to spreadsheet, not spreadsheet to form. In other words, if you modify a response in your spreadsheet, you’re not changing the original response, which will show up in summary view or the CSV download.

Keep responses only in Forms

If you don’t want responses to go to a spreadsheet, click the Keep responses only in Forms button. Then, to access the responses you’ve collected, click the File menu, select Download as, and click Comma Separated Values.

Keeping responses in Forms is a good way to go if you expect your form to receive heavy traffic or a significant number of responses, as spreadsheets will hold only the first 400,000 cells of response values. Your form’s summary view, as well as the results you download as a CSV, will always reflect all of the form responses that are submitted, even beyond these limits.
Google Forms – How To

Change your response destination

If you've chosen a spreadsheet in which to store your form responses, you can change this destination at any time by clicking on the Responses menu in Forms and selecting Change response destination. You'll be taken back to the “Choose response destination” dialog, where you can create a new spreadsheet or send responses to another existing spreadsheet.

Unlink a response spreadsheet

You can also choose to unlink your form from a spreadsheet at any given time by clicking on the Responses menu in Forms and selecting Unlink form. The spreadsheet will no longer receive new responses, but responses will continue to be stored in Forms, available as a real-time summary or as a CSV file. You can choose to re-link your form to a spreadsheet at any time with no responses lost or deleted.

Send your form to respondents

When you've completed your form, you can share it through email or social media. Just click the blue Send form button at the bottom of your form or at the top right corner of your browser window. You can share a link to your form, or you can add names, email addresses, and groups to the Add people field. Click the Done button, and the people you've added will receive an email directing them to your form.

Embed a form on a website or blog

If you'd like to embed your form on a website or blog, click the Send form button at the end of your form and select the Embed option. Or, go to the File menu and select Embed. You can then paste the generated HTML into your site or blog.
Send your form with a shortened URL

If you want a URL for your form that's easier to share, you can quickly create a short URL in Forms.

1. Create a form.
2. Click Send form in the upper right corner.
3. Check the box next to "Short URL." Uncheck the box to switch back to the original URL.

The URL for your form will automatically be shortened to a goo.gl/forms URL and you can add the URL to an email by copying and pasting the link.

Confirmation page settings

Before you send your form, you can choose what users can do after they submit their response. You can find these settings at the bottom of your form:

- **Show link to submit another response** — Allows users to submit as many form responses as they'd like.
- **Publish and show a link to the results of this form** — Gives respondents a summary of responses.
- **Allow responders to edit responses after submitting** — Allows respondents to change their answers to your form.

To change the confirmation message users will see, type your own message in the "Confirmation message" box.

Share your form with collaborators

If you're working on a form and would like to share it with a collaborator, click the File and select Add collaborators.... Then, from the "Sharing settings" dialog, you can specify individual collaborators with whom you'd like to share your form for editing. To add a collaborator, begin typing his or her name in the "Invite people" text box.

When you're working with a collaborator on a form, each of you can edit one input field at a time. For example, your collaborator can edit the text of a question while you edit the help text of that same question.

When you share a Google form with a collaborator, you give that collaborator full editing access to the form. That collaborator will have the ability to make any changes they'd like to the form, including a change to where responses are collected. Learn more about collecting responses.

View and manage form responses

View responses

Once you've created your form and sent it to recipients, you're able to view the responses you've received in three different ways: as a summary of responses, in a separate spreadsheet, or as a downloaded CSV. If you'd like a broad overview of how your group of respondents answered each question, viewing the summary is the way to go. If you'd prefer a fine-grained perspective on all the data you've collected with your form, you'll likely want to view the responses in a spreadsheet or download a CSV with response data.
View the summary of responses

To quickly see how many users filled out a form and what their responses are, you can check out the response summary. From your form, click the Responses menu and select Summary of responses. If you'd like respondents to be able to see this same summary of responses, check the box in the "Confirmation page" section of your form labeled Publish and show a link to the results of this form. When this box is checked, users who respond to your form will see a “See previous results” link, which they can click to view the response summary.

View form responses in a spreadsheet

To see a spreadsheet with responses to your form, click the View responses button in the toolbar. Learn more about storing responses in a spreadsheet.

Download responses as a CSV

To download all the responses your form has received, click the File menu, select Download as, and click Comma Separated Values.

Manage responses

Limit users to one response per form

If you want to keep users from submitting your form more than once, check the box next to "Limit to one response per user" in the "Form Settings" section at the top of the form.

Please note that while users will be asked to log in to their Google Account in order to access and fill out the form, their actual usernames will not be recorded.

Stop collecting form responses

To close your form to new responses, click the Accepting Responses button in the toolbar to toggle responses off. The toolbar button will then say "Not accepting responses." If you’d like to re-open your form to responses again later, you can click this button again to toggle responses back on.

If a form is no longer accepting responses, visitors to the form will see a message letting them know their responses won't be collected. To customize this message, change the text that appears under the heading "This form has been turned off," which appears near the top of your form.

Copy a form or spreadsheet

You can copy any form or spreadsheet by clicking the File menu and selecting Make a copy. Copying a form will copy only the questions and layout, not the responses you've already received.
Edit form responses after submitting

For form owners and creators

If you've created a form, you can allow form respondents to edit their responses by checking the box labeled **Allow responders to edit responses after submitting**, which you can find at the bottom of your form. If you enable this option, your form respondents will be able to edit the responses they've submitted to your form. These edits will be reflected in your spreadsheet and in your summary of responses.

Form respondents will be able to change their responses by clicking **Edit your response** on the form submission confirmation page.

You can also edit form responses received in your spreadsheet (if, for example, you'd like to correct a typo). It is important to note, though, that if you edit a response in your spreadsheet, you will not be overriding the original response in Forms, only the copy of the response in your spreadsheet. If the original respondent edits his or her response at a later time, the edited response will override any changes made manually in the spreadsheet.

**Google Apps settings**

If you're a Google Apps user, you'll see a box at the top of your forms that allows you to edit settings specific to your domain. Checking the first box, **Require [your domain] login to view this form**, will prevent respondents from seeing your form without first logging in. Checking the second box, **Automatically collect respondent’s [your domain] username**, will collect respondents' usernames and then send them an email with a copy of their form responses. That email will have an **Edit your response** link that will allow them to edit their form responses — that is, if you've enabled that option.

**For form respondents**

If the creator of a form sent to you has enabled the **Allow users to edit responses** option, you'll be able to edit your responses to the form. There are two ways to do this: from your email confirmation or on the form submission confirmation page.

If you check the **Send me a copy of my responses** box on the form, you'll receive an email confirmation showing your form responses. If you click the **Edit your response** link in the confirmation email, you'll be taken to a screen that allows you to edit your responses.

Once you click **Submit** on the form, these changes will be reflected in the form owner's spreadsheet and in the summary of responses. You can edit your responses as many times as you'd like using the **Edit your response** link.

You can also edit your form responses on the form submission confirmation page. On the confirmation page, click the **Edit your response** link. You'll be able to see your previous answers and make edits. Once you click **Submit** on the form, these changes will be reflected in the form owner's spreadsheet and in the summary of responses.
Pre-populate form answers

If you'd like to send respondents a form with some fields already filled in, Google Forms makes it easy. Here's how to pre-populate form answer fields:

1. While working on your form, click the Responses menu, then select Get pre-filled URL.
2. Fill in any answer fields you'd like to pre-populate.
3. Click Submit.
4. To send the pre-populated form to respondents, use the URL provided.

Validate answers in your form

With Google Forms, you can make sure that respondents fill out answers in accordance with guidelines that you set. For example, if you ask respondents for their email addresses, you can tell Google Forms to accept only email addresses that are properly formatted.

![Data validation](image)

Here's how to set up validation:

1. Create a form.
2. From the Insert menu, select “Text”, “Paragraph text”, “Checkboxes”, or “Grid” from the list. (Note: These are currently the only question types that support data validation.)
3. Click Data validation at the bottom of the question to show the data validation options.
4. There are several ways Google Forms can validate form data. (These are described below, in the “Data validation settings” section.) Click the checkbox next to the validation types you'd like to enable, and adjust the options associated with each validation type.
5. Respondents who enter invalid responses see an error message. You can modify this error message using the textbox on the far right.

Data validation settings

Currently, only “Text”, “Paragraph text”, “Checkboxes”, and “Grid” questions have support for validation. Each question type has its own validation settings.

**Text**

Text fields have three types of validation settings:

- **Number**: Ensure the answer is a number of a certain type. For example, you can specify that the answer is a whole number or a number between 21 and 42.
Google Forms – How To

- **Text**: Ensure the answer is text with a certain property. For example, you can restrict answers to text containing the word “lollipop” or only accept email addresses.
- **Regular Expression**: Ensure that the text contains or matches a certain regular expression. (Regular expressions are powerful, but require some know-how. See the “Regular expressions” below to learn more.)

**Paragraph text**

Paragraph text fields have two possible types of validation settings:

- **Text**: Ensure that the answer can have up to or at least a certain number of characters. For example, you can restrict answers to have at most 100 characters.
- **Regular Expression**: Ensure that the text contains or matches a certain regular expression. (Regular expressions are powerful, but require some know-how. See the “Regular expressions” below to learn more.)

**Checkboxes**

Checkboxes have two possible types of validation settings:

- **Select at least**: Ensure that at least a certain number of checkboxes are checked in the answer.
- **Select at most**: Ensure that at most a certain number of checkboxes are checked in the answer.
- **Select exactly**: Ensure that exactly a certain number of checkboxes are checked in the answer.

**Grid**

Grid questions have only one validation setting:

- **Limit to one response per column**: Ensures that an option can only be selected once per column. For example, if you have 3 columns that contain bed firmness ratings labeled “too hard”, “too soft”, and “just right” along with 3 rows of names (Mama, Papa, and Baby), then this validation will make sure that each bed is only chosen once (in other words, two people can’t select a bed that’s "too soft").

**Regular Expressions**

Regular expressions provide a way to identify certain types of text, including particular characters, numbers, words, or patterns of characters. Regular expressions are particularly useful in pattern matching, as these searches are not restricted to a specific search term. Instead, searches return patterns that match the expression specified.

To use regular expressions in data validation for "Text" and "Paragraph text," select the **Regular expression** option in the validation settings.

**Terms used in regular expressions**

The table below shows a sample of just some of the expressions that Google Docs supports. There are, however, many other supported expressions users can employ.
<table>
<thead>
<tr>
<th>Expression</th>
<th>Description</th>
<th>Example</th>
<th>Matches</th>
<th>Does not match</th>
</tr>
</thead>
<tbody>
<tr>
<td>.</td>
<td>A period signifies any character in the given position.</td>
<td>d.</td>
<td>do, dog, dg, ads</td>
<td>fog, jog</td>
</tr>
<tr>
<td>*</td>
<td>An asterisk after a character signifies a search for that preceding character repeated 0 or more times.</td>
<td>do*g</td>
<td>dog, dg, dooog</td>
<td>dOg, doug</td>
</tr>
<tr>
<td>+</td>
<td>A plus after a character signifies a search for that character displayed 1 or more times.</td>
<td>do+g</td>
<td>dog, dooog</td>
<td>dg, dOg, doug</td>
</tr>
<tr>
<td>?</td>
<td>The previous expression is optional.</td>
<td>do?g</td>
<td>dg, dog</td>
<td>dOg, doug</td>
</tr>
<tr>
<td>^</td>
<td>A caret must be placed at the beginning of a regular expression and signifies that the string starts with the character(s) or sequence placed after the caret.</td>
<td>^[dh]og</td>
<td>dog, hog</td>
<td>A dog, his hog</td>
</tr>
<tr>
<td>$</td>
<td>A dollar sign must be placed at the end of a regular expression and signifies that the string ends with the character(s) or sequence placed before the dollar sign.</td>
<td>[dh]og$</td>
<td>dog, hog, hot dog</td>
<td>dogs, hog, doggy</td>
</tr>
<tr>
<td>{A, B}</td>
<td>The previous expression is repeated between A and B times, where A and B are numbers.</td>
<td>d(o{1,2})g</td>
<td>dog, doog</td>
<td>dg, dooog, dOg</td>
</tr>
<tr>
<td>[x], [xa], [xa5]</td>
<td>A character set indicates that just one of the given character(s) should occur in the current position. For the most part, any characters are valid within brackets, including characters mentioned previously in expressions: [xa,$5Gg.]</td>
<td>d[ou]g</td>
<td>dog, dug</td>
<td>dg, dOg, dooog</td>
</tr>
<tr>
<td>[a-z]</td>
<td>A character set range signifies a search for a character within the given range of characters. Common ranges include a-z, A-Z, and 0-9. Ranges can be combined into a single range: [a-zA-Z0-9]. Ranges can also be combined with character sets (mentioned previously): [a-zA-Z,a*,].</td>
<td>d[o-u]g</td>
<td>dog, dug, dpg, drg</td>
<td>dg, dOg, dag</td>
</tr>
<tr>
<td>[^a-fDEF]</td>
<td>A character set beginning with a ^ signifies a search for a character that is not within the given set.</td>
<td>d[^aeu]g</td>
<td>dog, dOg, dig, d$g</td>
<td>dg, dag, deg, dug</td>
</tr>
<tr>
<td>\s</td>
<td>Any white space character.</td>
<td>d\sg</td>
<td>d g, d[TAB]g</td>
<td>dg, dog, doug</td>
</tr>
</tbody>
</table>
NOTE: When trying to search for actual instances of any character that has a specific meaning in regular expressions, like ^ and $, you need to “escape” the character in your search query by placing a backslash in front of it. For example, if you wanted to search for an instance of the $ character, you’d write \$.

Below are a couple of examples of how regular expressions could be used to search a spreadsheet:

**Search for cells that contain dollar amounts**

Enter the following in the Find bar: ^\$([0-9,]+)?\[0-9]+

This signifies a dollar amount where the first number is any number 0-9 or comma occurring zero or more times, followed by [,], followed by any number 0-9 repeated one or more times. This search would return any of the following: $4.666, $17.86, $7.76, $.54, $900,001.00, $523,877,231.56

**Search for cells containing US zip codes**

Enter the following into the Find bar: [0-9]{5}(-[0-9]{4})?

This signifies a U.S. zip code consisting of five numbers with an optional hyphen and four-digit add-on.

**Search for cells containing names beginning with a lowercase letter**

Enter the following into the Find bar: ^[a-z].*

This signifies a cell input that contains a lowercase letter followed by another character 0 or more times. This search would return any of the following: bob, jim, george, martin

**Deleting a form or form responses**

Delete a form or spreadsheet with responses

When you collect responses to your form in a spreadsheet, you’ll have two related items in your Drive — the form and the spreadsheet. You’re able to delete either one from your Drive at any time. It’s important to keep in mind, though, that deleting one of these items will not delete the other. If you delete a form, the associated spreadsheet will not be deleted, and the responses collected in that spreadsheet will remain intact. If, on the other hand, you delete a spreadsheet with responses, the original form will not be deleted, and responses in the form will still be available. If you choose to collect responses in a new spreadsheet in the future, all the old responses will still arrive in the new spreadsheet.

Delete responses from within a form

From within a form, you can click the Respones menu and select Delete all responses to clear responses from within a form. Note that this will delete responses from the form (meaning they will be deleted from Summary view, and will not be included in any subsequent CSV downloads), but not from any spreadsheet these responses had previously been copied to. You can’t delete individual responses from a form.